[R] Rcmdr window border lost

John Fox jfox at mcmaster.ca
Mon Aug 20 04:22:07 CEST 2007

Dear Andy and Peter,

My apologies for chiming in so late, but I was out of town and just caught
up with R-help today (and an impressive amount of material accumulates on
R-help in a couple of weeks!).

Although I develop the Rcmdr package on a Windows system, I test it under
Linux as well -- most recently on Ubuntu 7.04 with R 2.5.0. Curiously, the
windows for Rcmdr 1.3-5 look normal to me, as I just verified, so I'm unable
to reproduce the problem, and wonder whether anyone else has seen it.

As well, setting options(Rmcdr=list(suppress.X11.warnings=TRUE)) should
suppress the X11 warnings that appear on some systems, but I thought that
this problem disappeared with R 2.4.0. See ?Commander.


------- original messages ------

Andy Weller wrote:
> OK, I tried completely removing and reinstalling R, but this has not 
> worked - I am still missing window borders for Rcmdr. I am certain that 
> everything is installed correctly and that all dependencies are met - 
> there must be something trivial I am missing?!
> Thanks in advance, Andy
> Andy Weller wrote:
>> Dear all,
>> I have recently lost my Rcmdr window borders (all my other programs have 
>> borders)! I am unsure of what I have done, although I have recently 
>> update.packages() in R... How can I reclaim them?
>> I am using:
>> Ubuntu Linux (Feisty)
>> R version 2.5.1
>> R Commander Version 1.3-5
This sort of behaviour is usually the fault of the window manager, not 
R/Rcmdr/tcltk. It's the WM's job to supply the various window 
decorations on a new window, so either it never got told that there was 
a window, or it somehow got into a confused state. Did you try 
restarting the WM (i.e., log out/in or reboot)? And which WM are we 
talking about?

Same combination works fine on Fedora 7, except for a load of messages 

Warning: X11 protocol error: BadWindow (invalid Window parameter)

>> I have deleted the folder: /usr/local/lib/R/site-library/Rcmdr and 
>> reinstalled Rcmdr with: install.packages("Rcmdr", dep=TRUE)
>> This has not solved my problem though.
>> Maybe I need to reinstall something else as well?
>> Thanks in advance, Andy

John Fox, Professor
Department of Sociology
McMaster University
Hamilton, Ontario
Canada L8S 4M4

More information about the R-help mailing list