[R] Problem installing packages

Deepankar Basu basu.15 at osu.edu
Thu Apr 19 22:04:43 CEST 2007

I tried to install the package "tseries" but could not do so. Any
suggestions are welcome. I am using Ubuntu Linux and here is what I did:

$ sudo R
Then once in R, I did

> install.packages("tseries", dep=TRUE)

which gave a long list of errors. Going through them, I saw that the
basic problem was that the package "grid" was not found by the packages
(like "lattice", "Hmisc", etc.) that were part of the dependencies for
"tseries". So, I tried installing the package "grid" but could not. Here
is what I did (and the result):

$ sudo R

Once in R, I did

> install.packages("grid", dep=TRUE)

And this is what I got as error message

Warning in install.packages("grid", dep = TRUE) :
         argument 'lib' is missing: using /usr/local/lib/R/site-library
--- Please select a CRAN mirror for use in this session ---
Loading Tcl/Tk interface ... done
dependency '‘grid’' is not available

How should I proceed?


More information about the R-help mailing list