[R] S4 Method Dispatch for Sealed Classes

Martin Maechler maechler at stat.math.ethz.ch
Fri Sep 1 17:51:33 CEST 2006

>>>>> "Thomas" == Thomas Koenig <thomas.koenig at epigenomics.com>
>>>>>     on 31 Aug 2006 18:36:57 +0200 writes:

    Thomas> I encounter a problem with method dispatch with S4
    Thomas> classes, using the 'sealed' parameter in setClass.


    Thomas> Tried on R 2.3.1 and R 2.4.0-devel (2006-08-29 r39012): same result.

Sorry for not being really helpful, 
but there have been substantial S4 related changes to R-devel
since r39012 -- particularly about method dispatch.

Could you also try to use last night's r39045 (or something newer)?

There are several R developers who are really eager testing the
new S4 code inside R-devel.
For those R-help readers not subscribed to R-devel and interested
it this: Please look at
and consider reading the "accompanying" paper by John Chambers
"How S4 Methods Work" .

Followups on this topic do rather belong to R-devel than R-help
I think.


More information about the R-help mailing list