[R] R solaris 64 (etc) build errors

elw at stderr.org elw at stderr.org
Wed Nov 8 05:28:16 CET 2006

Hello folks,

I found the following message in the web archives from a month or so back 
- I've now encountered this same problem while trying to update our local 
builds of R (on Solaris) from ~2.2.0 to 2.4.x.

I've tried both the official 2.4.0 source tarball, as well as yesterday's 
R-patched source.

I'm doing my builds on a T2000 running Solaris 10, patched up to date as 
of a week or so back, using the Sun Studio 11 compilers.  Very generic 
build flags - the same flags worked perfectly using an older version of R. 
Nothing special going on, here.

I'd appreciate any help that listies can provide.  I'm willing to try out 
any suggestions that folks are able to come up with.

Thanks a bunch,


School of Library and Information Science
Indiana University, Bloomington


From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Tue 10 Oct 2006 - 10:49:01 GMT

Which Solaris is this? I am not seeing any problems with our Solaris 8 
systems. Was the compiler built on that exact system? What gcc options 
were used (-std=gnu99, as recommended, for instance)?

It looks like a system header problem: __builtin_isnan ought to be built 
in, not an external entry point. Since R does not use it, you need to 
trace through the headers to see why isnan is expanding to it.

On Thu, 5 Oct 2006, roger koenker wrote:

> We have a solaris/sparc machine that has been running an old version
> of R-devel: Version 2.2.0 Under development (unstable) (2005-06-04
> r34577)
> which was built as m64 from sources. Attempting to upgrade to 2.4.0
> the configure step
> goes ok, but I'm getting early on from make:
>> gcc -m64 -L/opt/sfw/lib/sparcv9 -L/usr/lib/sparcv9
>> -L/usr/openwin/lib/sparcv9 -L/usr/local/lib -o R.bin Rmain.o
>> CConverters.o CommandLineArgs.o Rdynload.o Renviron.o RNG.o apply.o
>> arithmetic.o apse.o array.o attrib.o base.o bind.o builtin.o
>> character.o coerce.o colors.o complex.o connections.o context.o cov.o
>> cum.o dcf.o datetime.o debug.o deparse.o deriv.o dotcode.o dounzip.o
>> dstruct.o duplicate.o engine.o envir.o errors.o eval.o format.o
>> fourier.o gevents.o gram.o gram-ex.o graphics.o identical.o
>> internet.o
>> iosupport.o lapack.o list.o localecharset.o logic.o main.o mapply.o
>> match.o memory.o model.o names.o objects.o optim.o optimize.o
>> options.o par.o paste.o pcre.o platform.o plot.o plot3d.o plotmath.o
>> print.o printarray.o printvector.o printutils.o qsort.o random.o
>> regex.o registration.o relop.o rlocale.o saveload.o scan.o seq.o
>> serialize.o size.o sort.o source.o split.o sprintf.o startup.o
>> subassign.o subscript.o subset.o summary.o sysutils.o unique.o util.o
>> version.o vfonts.o xxxpr.o mkdtemp.o ../unix/libunix.a
>> ../appl/libappl.a ../nmath/libnmath.a -L../../lib -lRblas
>> -L/usr/local/encap/gf7764-3.4.3+2/lib/gcc/sparc64-sun-solaris2.9/3.4.3
>> -L/usr/ccs/bin/sparcv9 -L/usr/ccs/bin -L/usr/ccs/lib
>> -L/usr/local/encap/gf7764-3.4.3+2/lib/sparcv9
>> -L/usr/local/encap/gf7764-3.4.3+2/lib -lg2c -lm -lgcc_s
>> ../extra/zlib/libz.a ../extra/bzip2/libbz2.a ../extra/pcre/libpcre.a
>> ../extra/intl/libintl.a -lreadline -ltermcap -lnsl -lsocket -ldl -lm
>> Undefined first referenced
>> symbol in file
>> __builtin_isnan arithmetic.o
>> ld: fatal: Symbol referencing errors. No output written to R.bin
>> collect2: ld returned 1 exit status

More information about the R-help mailing list