[R] read.spss 'error reading system-file header'

Finn Sandø fs at fs-analyse.dk
Mon Jul 31 21:19:15 CEST 2006

When I try to import an spss sav file with read.spss() I am getting the 
following error
'Error in read.spss("X:\\xxxx.sav") : error reading system-file header' 
and the import process is aborted.
I have tried in v. 2.3.0 and 2.3.1
The sav-file loads without problems in spss v14 I have tried saving in 
older spss v7 but are getting the same result.
The read.spss() has other errors (the 'Unrecognized record type 7, 
subtype 7 encountered in system file') but it does not seem to have any 
This leads me to thinking that the spss.read() slowly is growing out of 
date which would be sad.
So question 1:
Does anyone know if these problems are going to be solved? I know the 
read.spss() function is build on the PSPP project so maybe it takes 
someone with c-knowledge to do something about it.
If someone is going to work on the problem I will be happy to help by 
testing and providing problematic test-files.
Question 2
Is there some way to import spss-sav files in this case other than save 
in a non-spss format?

More information about the R-help mailing list