[R] Problems with updating R-packages

Jonathan Baron baron at psych.upenn.edu
Mon Jan 2 22:15:52 CET 2006

On 01/02/06 21:56, Petar Milin wrote:
> Thanks to the detailed help with previous error message, I managed to
> update Design package. However, when I tried to update Matrix and lme4 I
> received an error message again:
> ...
> > /usr/bin/ld: cannot find -lblas-3
> > collect2: ld returned 1 exit status
> > make: *** [Matrix.so] Error 1
> > ERROR: compilation failed for package 'Matrix'
> > ** Removing '/usr/lib/R/site-library/Matrix'
> > ** Restoring previous '/usr/lib/R/site-library/Matrix'
> ...
> When I tried to search for lblas-3, following instruction of professor
> Jonathan Baron, Dirk Eddelbuettel and Martin Maechler, I could not find
> it.
> With:
> > dpkg -S lblas-3
> and
> > dpkg -S *-lblas-3*
> I received:
> > dpkg: *-lblas-3* not found.

Well, the other thing you can try, which I should have mentioned,
is RSiteSearch("cannot find lblas-3"), or something like that, or
go to http://finzi.psych.upenn.edu.

Apparently you aren't the only one to have this particular
problem, and the way to a solution is given in several replies to 
earlier messages in this list.  I cannot understand them because
they are all specific to Debian.  Do you have blas installed?  (I 
can't believe you got very far without it, though.)

Jonathan Baron, Professor of Psychology, University of Pennsylvania
Home page: http://www.sas.upenn.edu/~baron

More information about the R-help mailing list