[R] Problems with updating R-packages

Petar Milin pmilin at ff.ns.ac.yu
Mon Jan 2 21:56:18 CET 2006

Thanks to the detailed help with previous error message, I managed to
update Design package. However, when I tried to update Matrix and lme4 I
received an error message again:
> /usr/bin/ld: cannot find -lblas-3
> collect2: ld returned 1 exit status
> make: *** [Matrix.so] Error 1
> ERROR: compilation failed for package 'Matrix'
> ** Removing '/usr/lib/R/site-library/Matrix'
> ** Restoring previous '/usr/lib/R/site-library/Matrix'

When I tried to search for lblas-3, following instruction of professor
Jonathan Baron, Dirk Eddelbuettel and Martin Maechler, I could not find
> dpkg -S lblas-3
> dpkg -S *-lblas-3*
I received:
> dpkg: *-lblas-3* not found.

Without Matrix, it is not possible to have lme4 updated. Also, I would
like to have nlme and some other packages. The question is how should I
procees and not be tedious with questions to the Mailing list?

>>>>> "Jon" == Jonathan Baron <baron at psych.upenn.edu>
>>>>>     on Sat, 31 Dec 2005 08:08:49 -0500 writes:

    Jon> You may need to install glibc-devel or glibc-dev,
    Jon> depending on how Ubuntu works and depending on how you
    Jon> installed it.  (For Fedora, these are called "devel".)
    Jon> You may be missing a great many "devel" rpms, such as
    Jon> readline-devel, blas-devel, and so on, which you will
    Jon> need for other packages.

    Jon> I'm not sure how you are supposed to know this, if it
    Jon> is true, although you must of course start by looking
    Jon> at the error message itself, which tells you that the
    Jon> problem is not finding crti.o.

    Jon> Appendix C1 of the installation and administration
    Jon> guide does mention the need for "dev(el)," but does not
    Jon> mention glibc in particular.

    Jon> When these things happen to me, I search for the
    Jon> missing file, in this case crti.o, on Google or on some
    Jon> repository of rpms, such as http://rpm.pbone.net.  In
    Jon> this case, there is a lot of discussion on Google about
    Jon> the very error message you got, although it is
    Jon> probabaly all misleading.

    Jon> You can also see whether you actually have the file
    Jon> somewhere by saying

    Jon> slocate crti.o

    Jon> If you find it, you can discover which rpm it is part
    Jon> of by using its full path, e.g.,

    Jon> rpm -qf /usr/lib/crti.o

In Ubuntu (which is a Debian derivative), I directly search for
the file in the installed (debian) packages by

   dpkg -S crti.o

which returns

      libc6-dev: /usr/lib/crti.o

So with ubuntu/debian, you need the libc6-dev package, which you
install by e.g.,

	apt-get install libc6-dev


More information about the R-help mailing list