[R] installation problem with 2.3.0

Eric Evans eje4 at cornell.edu
Wed Apr 26 17:00:15 CEST 2006


I'm in the process of trying to upgrade our R software from version 2.2.3 
to 2.3.0 on our Sun workstations.  In the installation process I'm 
encountering some puzzling errors whe I do the 'make install.'  After 
installing the doc files successfully the installation process crashes 
while trying to install the etc files, with the following messages:

make[1]: Leaving directory `/usr/local/R-2.3.0/doc'
make[1]: Entering directory `/usr/local/R-2.3.0/etc'
installing etc ...
/bin/bash: -c: line 1: syntax error near unexpected token `;'
/bin/bash: -c: line 1: `for f in ; do  ../tools/install-sh -c -m 644 ${f} 
"/usr/local/lib/R/etc";  done'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/usr/local/R-2.3.0/etc'
make: *** [install] Error 1

I've been studying the Makefile trying to figure out what would cause such 
an error but so far I haven't been able to figure it out.  We are using 
Solaris 8 with GNU make version 3.79.1.  I've also tried using the Sun 
default make (i.e. /usr/ccs/bin/make) but I get the same result.  I've 
installed R (previous versions) many times on Solaris previously without 
any problems and I'm puzzled as to why we're encountering this problem in 
2.3.0.  Does anybody have any suggestions for things I can try to remedy 
this problem?

Thanks very much,

More information about the R-help mailing list