[R] R GUI for Linux?

White, Charles E WRAIR-Wash DC charles.edwin.white at us.army.mil
Mon May 30 17:51:50 CEST 2005

I feel your pain. <grin> I am a new Linux user who has spent most of the weekend trying to get a functional R setup. When I installed Fedora Core 3 (FC3) on my home computer, I thought using R in a terminal would be a snap. I installed R using the rpm packages and tried to use it with the FC3 default terminal (GNOME Terminal 2.7.3). Before long, I found out the terminal was rudely discarding output beyond a set number of lines. I could increase the number of lines kept by the terminal but that didn't strike me as an acceptable solution. Cutting to my stress relieving intermediate solution, I am currently using xemacs with ESS as my R programming environment under FC3. Eventually, I will want to run JGR as my programming environment and Rcmdr as both a teaching tool and means to distribute code to some of my clients. On my way to xemacs, I also tried to install emacs and gnomeGUI. I will briefly document my experience with trying to install each of these packages below:

XEMACS with ESS: XEMACS is within the 'walled garden' of packages tuned specifically to run under FC3 and XEMACS provides a tuned installation for ESS. Since I had already compiled R from source with shared libraries enabled (the rmp does not enable shared libraries), I don't know if XEMACS will work with the rpm version of R. Note also that I installed this package using yum; 'Add or Remove Applications' lists xemacs but wouldn't allow me to install.

JGR: I have installed jdk1.5.0_03 and MOST of the the output from make looks like JGR is compiling correctly. JavaGD and rJava are not finding jini.h. I don't see an explicit statement of how to start JGR but I assume that is done by typing JGR (or maybe jgr) in a terminal window. Nothing happens. Two potential problems are: (a) I never should have downloaded JavaGD and rJava from CRAN (they won't uninstall, deleting the directories doesn't stop the problem, and I can't use yum to remove R to start over because yum doesn't recognise that R is installed.) or (b) I need to uninstall some of the stray versions of java littering my hard drive. I haven't removed the symbolic link between jre1.5.0_02 and firefox.

Rcmdr: There are all sorts of things in FC3 that seem to be tcl/tk related but Rcmdr doesn't seem to work with them. Since some are part of the base FC3 installation, I'm nervious about replacing them or installing competing software. Potentially conflicting software in FC3 are listed below:

tcl.i386                                 8.4.7-2                installed
tclx.i386                                8.3.5-4                installed
db4-tcl.i386                             4.2.52-6               base
postgresql-tcl.i386                      7.4.8-1.FC3.1          updates-released
ruby-tcltk.i386                          1.8.2-1.FC3.1          updates-released
tcl-devel.i386                           8.4.7-2                base
tcl-html.i386                            8.4.7-2                base
tclx-devel.i386                          8.3.5-4                base
tclx-doc.i386                            8.3.5-4                base

EMACS with ESS: A version of EMACS is tuned to FC3 but ESS has to be obtained elsewhere. Installing ESS requires editing the hidden .emacs file. I know how to see hidden files but this one does not appear to be where the ESS directions say to look.

gnomeGUI: Error message says that I don't have Gnome installed. It would be nice and GNU to have a working copy of gnome GUI.

I hope you have found my message to be entertaining. If anybody can stop me before I do something else stupid, I'd appreciate it. Thanks.


Charles E. White, Senior Biostatistician, MS
Walter Reed Army Institute of Research
503 Robert Grant Ave., Room 1w102
Silver Spring, MD 20910-1557
Personal/Professional Site: http://users.starpower.net/cwhite571/professional/

More information about the R-help mailing list