[R] make check fails after building R 2.1.0 on Fedora Core 3

Peter Dalgaard p.dalgaard at biostat.ku.dk
Sat May 14 22:39:20 CEST 2005

Bill Barnard <bill at barnard-engineering.com> writes:

> I have R v2.0.1 already running on the machine in question; a fairly
> generic Fedora Core 3 machine. I am trying to build the new version
> 2.1.0 and have not been able to troubleshoot the problem I encountered.
> I'm hoping someone else has seen it and can suggest a troubleshooting
> avenue to me.
> The build succeeds, both from the source RPM and from the tarball. I
> believed I had all the build prerequisites, based on reading the install
> instructions in the tarball and the R.spec file. The make check step
> fails almost immediately with:
> [billb at tioga R-2.1.0]$ make check
> ...
> make[4]: Entering directory `/home/billb/tmp/R-2.1.0/tests/Examples'
> running code in 'base-Ex.R' ...make[4]: *** [base-Ex.Rout] Error 1
> make[4]: Leaving directory `/home/billb/tmp/R-2.1.0/tests/Examples'
> make[3]: *** [test-Examples-Base] Error 2
> ...
> The output file:
> [billb at tioga R-2.1.0]$ tail -5 tests/Examples/base-Ex.Rout.fail
> > assign("ptime", proc.time(), env = .CheckExEnv)
> > grDevices::postscript("base-Examples.ps")
> Error in .Internal(PS(file, old$paper, old$family, old$encoding, old
> $bg,  :
>         no internal function "PS"
> Execution halted
> If I run the executable I built, and make a call to the postscript()
> function, I get the same error.
> I would appreciate any hints on how to troubleshoot this.

Odd... It's not like noone has been building on FC3 before. 

Have you tried the binary RPM? Does postscript() work there?

The error message is pretty puzzling. My version of 2.1.0 has 
grDevices::postscript ending with

    .External("PostScript", file, old$paper, old$family, old$encoding,
        old$bg, old$fg, old$width, old$height, old$horizontal,
        old$pointsize, old$onefile, old$pagecentre, old$print.it,
        old$command, title, fonts, PACKAGE = "grDevices")

.Internal(PS(file,....  sounds like it might come from an earlier
version of R. It doesn't appear in my version of the 2.1.0(-patched)

   O__  ---- Peter Dalgaard             Blegdamsvej 3  
  c/ /'_ --- Dept. of Biostatistics     2200 Cph. N   
 (*) \(*) -- University of Copenhagen   Denmark      Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard at biostat.ku.dk)             FAX: (+45) 35327907

More information about the R-help mailing list