[R] rw2001 RMA in GeenSpring "Error in sigToEnv"

Adaikalavan Ramasamy ramasamy at cancer.org.uk
Mon Feb 21 19:27:07 CET 2005

The sigToEnv error has been reported several times on the BioConductor
mailing list in this month. See :


There have not been much discussion on this. Either the problem was
solved by something simple such as upgrading to the latest version or
the authors are busy trying to find a fix. In any case, it would be
better to consult the authors or the BioConductor mailing list first.

Regards, Adai

On Mon, 2005-02-21 at 16:12 +0000, Duncan Murdoch wrote:
> On Mon, 21 Feb 2005 14:57:13 -0000, "Liu, Xin" <Xin.Liu at arradx.com>
> wrote :
> >Dear all,
> >
> >What I use is the latest version of R: rw2001. And I got the following error message when I run RMA in GeneSpring:
> >
> >Error in sigToEnv(signature, fdef) : Trying to get slot "signature" from an object of a basic class ("NULL") with no slots
> >In addition: Warning message: 
> >Incompatible phenoData object. Created a new one.
> > in: read.affybatch(filenames = files)
> >
> >Which information I should provide furthur or the latest version of R has some bugs?
> >Thanks a lot!
> >
> >Xin LIU
> That looks like a bug in GeneSpring, or at least an incompatibility
> with the latest version of R.  You want to contact its authors.  
> Duncan Murdoch
> ______________________________________________
> R-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html

More information about the R-help mailing list