[R] Trouble with SciViews-R 0.7-3, SciViews R 0.8-7, and Tinn-R

Bing Ho 2bingho at stanford.edu
Wed Aug 3 02:42:14 CEST 2005

Hello everybody,

I am new to using Windows and R, and have been experimenting with various

I recently installed R 2.1.1 under Windows XP SP2, and tried installing the
latest versions of SciViews (0.7-6, and R package 0.8-7 found on the
sciviews.org website), and also Tinn-R stable. I have also been
experimenting with R Commander 0.9-14 stable, 1.0-2 stable, and also tried
1.1 unstable (along with dependent packages).

Oddly, although the installer for SciViews says version 0.7-3, the About
dialog box says 0.7.6. I am not certain which is the correct version.

I have confirmed incompatibility with the latest stable and unstable R
Commander and SciViews (recently noted by Grosjean in R-help). R Commander
0.9-14 does work with SciViews 0.7.6 (.3?), but also produces the
previously reported error that R Commander is not installed (answering "No"
to installing, will allow the correct dialog box to open).

I have noticed the following additional two behaviours which have
consistently been produced.

1. After installing SciViews 0.8-7 package from the SciViews website, the
call-tip functionality is broken in Tinn-R stable. Downgrading, or
installing, the SciViews 0.8-6 from CRAN restores, or enables, this

2. The Packages menu in SciViews-R 0.7.3 is hopelessly broken for me (at
least under R 2.1.1). The only menu option that works sometimes, for
reasons I am unable to elucidate, is Load packages (the first option);
however, many times Rconsole crashes altogether. The other menu choices
result in nothing happening. I am able to replicate this behaviour with
multiple fresh installs of R 2.1.1, SciViews 0.7-6 (3?) (and SciViews 0.8.7
package), and tcltk2 0.7-4.

I am not sure that these reports matter since it appears that SciViews will
shortly be updated, but since I found no mention of these issues, I am
hopeful that the next version may fix them.

More information about the R-help mailing list