[R] R can not show plots (in Mac OS X terminal)

Tony Han Bao tonybao at mac.com
Tue Apr 5 22:30:51 CEST 2005

On 5 Apr 2005, at 8:45 pm, Minyu Chen wrote:

> No, the only output is postscipt. As I just install X11, I did not 
> have it before compiling R.
You can try to set the device to x11 by issue the following command,

options(device = 'x11')

and hope now it works.

> What to do now except for getting and compiling R Aqua?
Getting and compiling R Aqua is quite easy and you should do so for OS 
X to make use of its quartz and easy pdf related features.

All the best,
> Thanks,
> Minyu Chen
> On 5 Apr 2005, at 20:23, Tony Han Bao wrote:
>> On 5 Apr 2005, at 19:12, Minyu Chen wrote:
>>> Dear all:
>>> I am a newbie in Mac. Just installed R and found R did not react on 
>>> my command plot (I use command line in terminal). It did not give me 
>>> any error message, either. All it did was just giving out a new 
>>> command prompt--no reaction to the plot command. I suppose whenever 
>>> I gives out a command of plot, it will invoke the AquaTerm for a 
>>> small graph, as I experience in octave. What can I do for it?
>> issue command
>> >getOption("device")
>> to check the output device. The default I have on OS X is X11, do you 
>> have it installed before compiling R?
>> It could also be the case that you issued command such as 
>> postscript() before plot(...) but forgot to issue dev.off().
>>> Many thanks,
>>> Minyu Chen
>>> ______________________________________________
>>> R-help at stat.math.ethz.ch mailing list
>>> https://stat.ethz.ch/mailman/listinfo/r-help
>>> PLEASE do read the posting guide! 
>>> http://www.R-project.org/posting-guide.html
Tony Han Bao
tonybao at mac.com

More information about the R-help mailing list