[R] question about Rcmd SHLIB

Duncan Murdoch murdoch at stats.uwo.ca
Sun Oct 17 22:20:29 CEST 2004

On Sun, 17 Oct 2004 16:08:04 -0400, "Liqiang Ni" <lni at mail.ucf.edu>

>Dear R-people:
>I tried to create a shared library in Windows XP. However I got error
>messages which attached below:
>C:\lasso>Rcmd SHLIB all.f cox.f
>gcc    all.o libR makeMakedeps all.dll   -o all
>gcc.exe: libR: No such file or directory
>gcc.exe: makeMakedeps: No such file or directory
>make: *** [all] Error 1
>I have created shard libraries successfully before. Also for the same
>fortran files: all.f cox.f, I can create the object all.so successfully
>in Linux using R SHLIB. Any suggestion? Thanks. 

You don't say which versions you're using.  I just tried this in
version 2.0.0, and got the following:

$ Rcmd SHLIB test.f test2.f
g77 -O2 -Wall   -c test.f -o test.o
g77 -O2 -Wall   -c test2.f -o test2.o
ar cr test.a test.o test2.o
ranlib test.a
gcc  --shared -s  -o test.dll test.def test.a
-Lf:/R/rw2000/src/gnuwin32  -lg2c

So it looks to me as though you're not using the same SHLIB script as
me, or there's something wrong with your setup.  Did you set up your
path the way README.packages advises?

Duncan Murdoch

More information about the R-help mailing list