[R] Building package compatible w/ R v1.9.1 and R v2.0.0?

Henrik Bengtsson hb at maths.lth.se
Fri Oct 15 18:14:20 CEST 2004


just in the process of updating my packages for R v2.0.0 and I have not had
time to followed the R v2.0.0 discussions so maybe my questions have already
been answered.

A concern I have is that when creating packages they should be backward
compatible with R v1.9.x for a while until all users and computers has
migrated to R v2.0.x. It is pretty straightforward to setup my packages so
that they will *build from source* smoothly under both R v1.9.1 and R

But, is there an easy way to to build a binary (read Windows binary) so that
it will install on R v2.0.0 as well as Rv1.9.1, or do I "have to" provide
two seperate builds?  

As you already know, current status is that building under R v2.0.0 and
loading in R v1.9.1 gives the error:

Error in firstlib(which.lib.loc, package) :
        couldn't find function "lazyLoad"
In addition: Warning message:
package R.oo was built under R version 2.0.0

and building under R v1.9.1 and loading in R v2.0.0 gives the error:

Error in library(R.oo) : 'R.oo' is not a valid package -- installed < 2.0.0?

Just to give it a try, I tried to build the package under R v2.0.0 with
"LazyLoad: FALSE" in DESCRIPTION, but with the same error.

Best wishes

Henrik Bengtsson

Dept. of Mathematical Statistics @ Centre for Mathematical Sciences 
Lund Institute of Technology/Lund University, Sweden (+2h UTC)
+46 46 2229611 (off), +46 708 909208 (cell), +46 46 2224623 (fax)
h b @ m a t h s . l t h . s e, http://www.maths.lth.se/~hb/

More information about the R-help mailing list