[R] Diagnosing trouble with R-2.0, Fedora Core 2, and Rcmdf

John Fox jfox at mcmaster.ca
Wed Oct 13 02:23:08 CEST 2004

Dear Paul,

I've now had a chance to check into these problems further:

> -----Original Message-----
> From: r-help-bounces at stat.math.ethz.ch 
> [mailto:r-help-bounces at stat.math.ethz.ch] On Behalf Of Paul Johnson
> Sent: Monday, October 11, 2004 1:09 PM
> To: r help
> Subject: [R] Diagnosing trouble with R-2.0, Fedora Core 2, and Rcmdf
> Greetings, R-help!
> On 2 Fedora Core 2 Linux systems, i've completely erased the 
> previous R and all packages and then installed R-2.0 and 
> installed fresh packages.
> In using Rcmdr, I see some trouble and I wonder if other 
> people see this and if it is due to the tcl/tk, or R, or 
> Rcmdr.  (If readers have not yet tried Rcmdr, I recommend it 
> not just because of the GUI it provides, but also because 
> Prof. Fox has created several very handy commands, like 
> scatter3d, which make it possible to use advanced packages like rgl. 
> Rcmdr provides several very handy wrapper commands that "just 
> work" and users don't have to fuss over so many details! And, 
> if you are new at R, you can use pull down menus and then 
> Rcmdr displays the commands that correspond with those menu 
> options. Very educational!)
> In no particular order, here are the issues I see with R-2.0 and Rcmdr
> 1. In the panel to select a dataset from a package (nenu: 
> Data/Data in packages), I can type in the name of a dataset, 
> but the GUI will not let me choose the name of a package from 
> which to select a dataset. Nothing happens when I pick a 
> package name.  (With previous R/Rcmdr, I did not have this trouble).

I had in fact fixed this in the development version of the package (Rcmdr
0.9-12). I've now posted that to my web site, at
<http://socserv.socsci.mcmaster.ca/jfox/Misc/Rcmdr/index.html>. I'd like to
do some more testing before sending this version to CRAN.

> 2. When using Rcmdr, some of the output from commands shows 
> in the Rcmdr bottom window, but some is sent to the xterm in 
> which R was started. For example, with a scatter3d() command, 
> if I add the option model.summary=T, the model summary shows 
> in the xterm.  But some other models show results in the 
> bottom pane of Rcmdr.  And, it seems to me, there are some 
> commands in which I've noticed some of the output going to 
> the Rcmdr bottom buffer and  some to the xterm.

I did in fact try to deal with this problem. The solution that I employed
didn't work for scatter3d() with model.summary=TRUE, since the printed
summaries were produced as side effects by scatter3d(). That's a bad
practice, and I've fixed it; now scatter3d() returns a list of summaries,
and the Rcmdr can cope with that. (As you know, it's not my intention that
model.summary=TRUE be set from the Rcmdr GUI, but it's better to have it
work if you enter this from the script editor.)

You imply, however, that there are other cases of this problem. It would
help to know what they are -- assuming that they're not fixed in the
development version now on my web site.

> 3. When I want to exit Rcmdr and choose the pull down "exit 
> from Commander and R", I get a Segmentation Fault that closes 
> Rcmdr and R.

I haven't been able to duplicate this problem, to this point testing only
under Windows XP. Does this occur only when an rgl graphics device is open?
(The Rcmdr should close the rgl device before it exits.)

> 4. 3d plots do not display on the screen until I click in the 
> rgl window that displays the graph.  This might be a video 
> card/AGP driver problem, I suppose.  These systems have the 
> NVidia FX5200 cards and the NVidia proprietary X driver.  If 
> other users don't see the same on other kinds of systems, I 
> guess that will tell me where the problem lies.

As I said, I believe that I've seen this problem before under Quantian. It
would help to know whether it's peculiar to the Rcmdr, scatter3d(), or rgl.

> 5. At random times, I get an error tcl/tk window popping up 
> with a message about MASS and categorical variables.  It says
> Error in data(package=parse(text=packageName));
> 'MASS' must be character string or NULL
> It says that over and over, sometimes it has other package 
> names, as in:
> Error in data(package=parse(text=packageName));
> 'relimp' must be character string or NULL
> These seem to be harmless?

This should go away now that problem 1 is fixed.


> -- 
> Paul E. Johnson                       email: pauljohn at ku.edu
> Dept. of Political Science            http://lark.cc.ku.edu/~pauljohn
> 1541 Lilac Lane, Rm 504
> University of Kansas                  Office: (785) 864-9086
> Lawrence, Kansas 66044-3177           FAX: (785) 864-5700
> ______________________________________________
> R-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! 
> http://www.R-project.org/posting-guide.html

More information about the R-help mailing list