[R] problem Installing R 2.0.0 on SuSe 9.1

Christopher Albert chris.albert at mcgill.ca
Sat Oct 9 15:16:40 CEST 2004


	I first tried it by using ./configure with the source files, but
found that there is a huge problem with the gcc-g77 package, then I
tried using the RPM obtained from CRAN, getting the following, the first
of which appears to be another manifestation of the g77 problem:

linux:/tmp # rpm -i R-base-2.0.0-1.i586.rpm
warning: R-base-2.0.0-1.i586.rpm: V3 DSA signature: NOKEY, key ID
error: Failed dependencies:
        libg2c.so.0 is needed by R-base-2.0.0-1
        libglade-gnome.so.0 is needed by R-base-2.0.0-1
        libglade.so.0 is needed by R-base-2.0.0-1

Do you have a suggestion about what I (a suse beginner) should do in
order to get R up and running under suse 9.1?  I have done some looking
around and I do not see any package on suse for version 3.3.3 of the
gcc-g77 package that corresponds to the gcc-g++ version 3.3.3, and I
don't know if I am up to changing the versions of everything, so I hope
I don't have to do that.  Thanks in advance.

I'm not a Suse user, but this probably means you are missing a couple
packages that a required for the install. 
On a Fedora 2 box :
[albert at pentaquark albert]$ rpm -qf /usr/lib/libg2c.so.0
[albert at pentaquark albert]$ rpm -qf /usr/lib/libglade-gnome.so.0
[albert at pentaquark albert]$ rpm -qf /usr/lib/libglade.so.0
[albert at pentaquark albert]$

Do you have those files? If not, you might just need to install a couple
of rpms, libf2c and libglade. They seem to be available for 9.1:


What does "rpm -q f2c libglade" tell you?


More information about the R-help mailing list