[R] R works on Fedora Core 3

Roger D. Peng rpeng at jhsph.edu
Thu Nov 11 14:10:18 CET 2004

I've run into this title bar problem on FC1 and FC2 (not tried FC3 
yet) when I compile from sources.  I figured it was just a weird 
window manager bug.  I find that if I maximize the window (Alt-F10, on 
my system) and then restore the window to its original size (Alt-F5), 
I get the title bar back.


Gavin Simpson wrote:
> Martyn Plummer wrote:
>> On Wed, 2004-11-10 at 09:19 +0100, Martyn Plummer wrote:
> <snip>
>> An RPM for Fedora Core 3 should be on a CRAN mirror near you by the
>> weekend. This fixes the printcmd bug.
>> The X11() window is the right size for me, but it doesn't have a title
>> bar, which is a nuisance.
>> Martyn
> I have this "problem" with both your rpm on FC2 and when compiled from 
> sources (1.9.1-patched 2.0.0-patched [now 2.0.1 beta]). The title bar 
> comes and goes, seemingly at random (I've not systematically test this 
> so I haven't found an underlying cause) when a new X11() device is 
> started. Mainly a more complex plot (over several lines and commands) 
> will fail to produce the title bar, if I then close that device and open 
> another using something simple, say plot(1:10) then I more often than 
> not get the title bar. I say more often than not, because sometimes I 
> have to run that command a few times, closing the opened faulty device 
> window in between to get the title bar to appear. Same result running R 
> from within xemacs/ess.
> Gav

Roger D. Peng

More information about the R-help mailing list