[R] RSPerl problem with testing

Alicia Amadoz Alicia.Amadoz at uv.es
Thu Nov 11 10:29:58 CET 2004


I'm trying to install de RSPerl module and i have some problems trying
to test it. I've tried to contact with the author but the e-mail address
seems not to exist. Hope that anyone in this list could explain me a
little about this problem. I have a bash shell and what i do is the

# export PERLLIB
# LD_LIBRARY_PATH=/usr/lib/R/bin:/usr/lib/R/library/RSPerl/libs
# perl test.pl
Can't load '/usr/lib/R/library/RSPerl/share/blib/arch/auto/R/R.so' for
module R: /usr/lib/R/library/RSPerl/libs/libPerlConverter.so: undefined
symbol: R_GlobalEnv at
/usr/lib/perl5/5.8.3/i386-linux-thread-multi/DynaLoader.pm line 229.
 at test.pl line 11
Compilation failed in require at test.pl line 11.
BEGIN failed--compilation aborted at test.pl line 11.
not ok 1

I move to the /usr/local/src to test again and  i get the same error.

Any help would be much appreciated. Thanks.


Alicia Amadoz
Evolutionary Genetics Unit
Cavanilles Institute for Biodiversity and Evolutionary
University of Valencia
Apartado Oficial 22085
E-46071 Valencia SPAIN
Phone: (+34) 96 354 3687
FAX: (+34) 96 354 3670
e-mail: alicia.amadoz at uv.es
NOTE! For shipments by EXPRESS COURIER use "Instituto
Cavanilles de Biodiversidad y Biología Evolutiva,
Polígono de la Coma s/n, 46980 Paterna (Valencia),
Spain" instead of P.O. Box no. and Post Code/City above.

More information about the R-help mailing list