[R] Compilation error on mgcv_1.1-7 on OS X (10.3)

Jon Egil Strand jes at luretanker.no
Thu Nov 4 18:02:36 CET 2004

> I expect your version of R was not compiled on your own system, although 
> you don't say (please see the posting guide).  (I also presume this is a 
> Macintosh but you could have said.)

Prof Ripley, thank you for your answer. 

Indeed you are correct in that I was using precompiled R-2.0 on a 

> > I run into a compilation error when updating to mgcv_1.1-7 in R 2.0.0 on 
> > OS X 10.3. Note that other pacakges have compiled nicely. 
> Packages containing Fortran source code?

Following your suggestion of building R from source I ran into problems 
due to a lack of a fortran compiler (or f2c). It turns out half a gigabyte 
of compiler tools from the Xcode package wasn't enough, Apple left out any 
fortran tools. Hmpf. I transformed the iBook to a pure gentoo linux 
machine, and everything compiles like a charm. 

All the best

Jon Egil Strand

More information about the R-help mailing list