[R] R via ssh login on OS X?

James Howison jhowison at syr.edu
Tue Jun 29 09:04:36 CEST 2004

On Jun 29, 2004, at 1:22 AM, Ulises Mora Alvarez wrote:

> Hi!
> If you are trying to log in from another Mac to the G5 there are some
> details to bear in mind, though. If you are indeed trying from a Mac, 
> I'd
> suggest you to launch your local X server; then, from an xterm 'ssh 
> -X...'
> to the G5. Of course, if the sshd on the G5 is configured so that its
> /etc/sshd_config says 'X11Forwarding no' you'll be not able to use the 
> X11
> device for graphics; but you can search for a solution on the list
> files.

That's good thinking.  That hadn't occurred to me and would be great 
for the graphical stuff.  Goes to show that Xwindows has the right idea 
for networked graphics while aqua is hopeless in that regard.

I don't think that this problem happens in R-1.9.1 because if I ssh 
into my laptop from a remote box as a non-logged-in user R behaves 
perfectly on the commandline.  Or maybe the install on the G5 is 

Happily I have managed to solve my immediate problem on the G5 by 
compiling a copy of R in my home directory.  This wasn't the easiest 
primarily because I didn't have f2c installed (and because I don't have 
root I couldn't put it in the normal place).  I'm going to say how I 
did it in case this is handy for others (frankly I hope others don't 
have to go through this ;)

I grabbed the f2c code from 
and libf2c from http://www.netlib.org/f2c/libf2c.zip

Both built ok.  I moved the f2c executable, f2c.h and libf2c.a into 
~/f2c.  Don't forget to run ranlib over libf2c

I set the environment variables:

CPPFLAGS=-I$HOME/f2c/   (for some reason the --includedir just didn't 
seem to work ...)

(had to remember to do this before configure)

then did

./configure --prefix=$HOME/Rinstall/ --enable-R-framework=no 
--with-x=no --with-lapack=no

and then


This basically worked but for some reason lapack was still trying to 
build and that was failing, so I deleted it from the appropriate 
makefile and the rest of the compile went fine.  The lapack confusion 
stopped some of the recommended modules from building but I didn't need 
those (just sna which built fine from CRAN).

I didn't do the actual install but am just using the full path to R.  
It is working fine in command-line mode now and the calculations are 
running as I type.

I didn't test this but I did also read that people are able to get 
around the "need graphical launching access" by using OS X fast user 

Thanks everyone!


> Good look.
> On Mon, 28 Jun 2004, Paul Roebuck wrote:
>> On Mon, 28 Jun 2004, James Howison wrote:
>>> I have an ssh only login to a G5 on which I am hoping to run some
>>> analyses.  The situation is complicated by the fact that the 
>>> computer's
>>> owner is away for the summer (and thus also only has shell login).
>>> R is installed and there is a symlink to /usr/local/bin/R but when I
>>> try to launch it I get:
>>> [jhowison at euro]$ R
>>> kCGErrorRangeCheck : Window Server communications from outside of
>>> session allowed for root and console user only
>>> INIT_Processeses(), could not establish the default connection to the
>>> WindowServer.Abort trap
>>> I though, ah ha, I need to tell it not to use the GUI but to no 
>>> avail:
>>> [jhowison at euro]$ R --gui=none
>>> kCGErrorRangeCheck : Window Server communications from outside of
>>> session allowed for root and console user only
>>> INIT_Processeses(), could not establish the default connection to the
>>> WindowServer.Abort trap
>>> I'm embarrassed to say that I'm writing to the list without having 
>>> the
>>> latest version installed---because I can't install it at the moment. 
>>>  I
>>> am using R 1.8.1.  I have tried to compile the latest from source but
>>> there is no F77 compiler. I thought I'd ask around before going down
>>> the "put local dependencies in the home folder" to compile this route
>>> (any hints on doing that would be great though) ...
>>> Can other people get R command-line to work with logged in remotely 
>>> via
>>> ssh?  Any hints?
>>> Is this something that is fixed in more recent versions?
>>> I think I can see one other route:  getting the computer's owner to
>>> install fink and their version remotely ... but I'm open to all 
>>> "don't
>>> bother the professor when he's on holiday" options ...
>> I suffered similarly attempting to run R via CGI; I never found
>> a workaround for remote access (also running 1.8.1 with Panther).
>> Seemed to have something to do with running an application requiring
>> access to graphics but not being the user currently "owning" the dock.
>> I did not determine if the limitation was due to R implementation or
>> operating system software.
>> F77 not necessary; use 'f2c' instead. But don't bother with Fink since
>> it's not necessary to build it. No 'sudo' access either? Is the user
>> still logged in (screenlocked) or are you just lacking administrative
>> access?
>> ----------------------------------------------------------
>> SIGSIG -- signature too long (core dumped)
>> ______________________________________________
>> R-help at stat.math.ethz.ch mailing list
>> https://www.stat.math.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide! 
>> http://www.R-project.org/posting-guide.html
> -- 
> Ulises M. Alvarez
> umalvarez at fata.unam.mx
+1 315 395 4056

More information about the R-help mailing list