[R] Problems loading dataset in Rcmdr

John Fox jfox at mcmaster.ca
Fri Feb 13 23:13:27 CET 2004

Dear CG,

These symptoms seem very odd to me, particularly since everything was 
working well until two days ago.

Is it possible that you have a saved workspace that is being loaded each 
time you run R? I don't believe that a saved workspace will be removed by 
an uninstall and reinstall of R (to the same location). It's possible, I 
suppose, that there's something in the workspace that is interfering with 
the Rcmdr.

If this proves not to be the case, does traceback() give you any useful 
information? Are you able to read data sets from any source in Rcmdr?

I hope this helps, but if it doesn't perhaps you can supply some more 


At 04:06 PM 2/13/2004 +0100, CG Pettersson wrote:
>Hello all!
>I´ve been using Rcmdr for some time, as a quick way of producing
>graphics and basic statistics. I run R1.8.1, OS W2000.
>Two days ago the dataset loader stopped working. Normally, the button
><No active dataset> is clickable to give you the opportunity to choose
>dataset to load in the Rcmdr context. Clicking on the button now
>produces this:
>Rcmdr Version 0.9-3
>Error in parse(file, n, text, prompt) : parse error
>What is happening and what could I do to get out of it?
>(I have removed Rcmdr and downloaded it again from CRAN, as well as
>uninstalled R, reinstalling it from the copy of my download.
>Doesn´t help so far.
>Please help!

John Fox
Department of Sociology
McMaster University
Hamilton, Ontario, Canada L8S 4M4
email: jfox at mcmaster.ca
phone: 905-525-9140x23604
web: www.socsci.mcmaster.ca/jfox

More information about the R-help mailing list