[R] R memory allocation error - Unix

Susan Shortreed susanms at stat.washington.edu
Fri Nov 21 20:16:43 CET 2003

I am using ESS on a unix system for my analysis.  My R environment
contains a 90118 by 94 dataframe.  I am trying to calculate the mean of a
column in this data frame and I am getting the following error:

Error: can not allocate a vector of size 704 Kb

I have tried
and this does not help.

when I call gc() this is what is returned
> gc()
           used (Mb) gc trigger  (Mb)
Ncells  1178845 31.5    2564037  68.5
Vcells 11666683 89.1   38686231 295.2

I tried calling mem.limits(nsize=1000000000000).  Any value for vsize
gives an NA error, and when I recall gc() the limit for Vcells is NA.
There is more than enough memory available on the Unix machine, when I
call top I am using 0.0% of the memory and the other handful of users are
using about 10% all together.  I have increased my  user memory limit
and that still did not help (I found an email in R-help archives
suggesting this).  It seems to me that 704Kb is a rather small size to
give an error and it appears to be available on the system.

Any suggestions?

Thank you,

More information about the R-help mailing list