[R] Compilation problem SuSE 9.0

Sven Sandin ueb901c at tninet.se
Tue Nov 11 17:33:12 CET 2003


I have problem running R (tried 1.8.0 and 1.7.1) under a fresh installed SuSE 
9.0 using default settings: I'm not able to send plots to the monitor. Only 
postscript graphs are produced in external files. When assigning 
options(device='X11') and then plotting I get the message "Error in X11() : 
X11 is not available".

Since this occured using the r-cran binary I tried to compile from source. 
However, the problem was not resolved. I do not have the competence for 
interpreting the output from the configure and make commands. Running the 
 ./configure  (also tried  ./configure --with-x) I read the following line:

checking for X... no

and at the bottom:

R is now configured for i686-pc-linux-gnu

  Source directory:          .
  Installation directory:    /usr/local

  C compiler:                gcc -D__NO_MATH_INLINES -mieee-fp -g -O2
  C++ compiler:              g++ -mieee-fp -g -O2
  Fortran compiler:          g77 -mieee-fp -g -O2

  Interfaces supported:
  External libraries:        readline
  Additional capabilities:   PNG, JPEG, bzip2, PCRE
  Options enabled:           R profiling

  Recommended packages:      yes

Thankful for any help on this matter.

More information about the R-help mailing list