[R] R-1.6.2: installation problem on Solaris 2.8

Bo Peng bpeng at stat.rice.edu
Thu Mar 20 16:23:40 CET 2003

On Thu, Mar 20, 2003 at 07:29:00AM +0000, ripley at stats.ox.ac.uk wrote:

> > I tried to compile R-1.6.2 from source on Solaris 2.8. There is no 
> > problem with configure and make. However, `make test' fails with error 
> > message:

> [...]

> > I am using gcc 3.2.1, I can supply further info if necessary.

> There is a bug in gcc-3.2.1 (and 3.2.2) on Solaris.  Don't use them.
> It has been reported and acknowledged by the gcc maintainers.

That is unfortunate. Is there any work-around? I tried to set 
environment variable cpp as /usr/site/gcc-2.95.3/bin/gcc or gcc-3.0.4 
but ./configure says

checking command to parse /usr/ccs/bin/nm -p output... ok
checking how to run the C preprocessor... /usr/site/gcc-2.95.3/bin/gcc
configure: error: C preprocessor "/usr/site/gcc-2.95.3/bin/gcc" fails sanity check
See `config.log' for more details.

Bo Peng

More information about the R-help mailing list