[R] tcltk makes R crash?

Kurt Sys kurt.sys at rug.ac.be
Mon Mar 3 13:18:09 CET 2003

Hello all,

I got a problem using the tcltk-package. It makes 'R crash':
I can use R and different packages without any problem. However, when I start the tcltk-package, the terminal I'm running R in (no matter what this 'terminal' is), will not recieve any input anymore once I set at statement which cannot be evaluated. The most easy example:
> library(tcltk)
> blabla
Error: Object "blabla" not found

So, when I give these two commands, the only thing I can do (with the terminal I run R in), is 'kill client' (which is the terminal).

Sometimes (I didn't find any logic yet), I cannot see the commands I'm writing, but they are evaluated anyway (so I can quit etc, using the command 'q()', but what I write is not shown on the screen and when I'm out of R, this behaviour doesn't change for the terminal I ran R in).

I'm using Debian woody, R 1.6.2.

Anyone any idea?

thanks in advance,

More information about the R-help mailing list