[R] R won't connect to the internet on SUSE Linux 8.1

michael watson (IAH-C) michael.watson at bbsrc.ac.uk
Fri Jul 25 10:23:59 CEST 2003


Thanks once again for your help, I do appreciate it..... however....

Here is what I get with your test.... (under tcsh - i normally use bash, but I will keep everything the same)

users/mwatson> env http_proxy=http://wwwcache.bbsrc.ac.uk:8080/ R

trying URL `http://cran.r-project.org/src/contrib/PACKAGES'
unable to connect to 'cran.r-project.org' on port 80
Error in download.file(url = paste(contriburl, "PACKAGES", sep = "/"), :
	cannot open URL 'http://cran.r-project.org/src/contrib/PACKAGES'

... and THATS IT!  I don't get any "Using HTTP proxy ... " message at all, which appears to suggest that R, under SUSE Linux 8.1, is NOT PICKING up the http_proxy environment variable - this isn't something thats wrong with my proxy, that works with everything else - internet browsers, ftp clients, wget, instant messenger clients etc etc.  The problem is R, which isn't picking up that it needs to use the http_proxy environment variable.  And I apologise for being blunt, but that is an R problem, not a proxy problem!

Thanks for your help


-----Original Message-----
From: Prof Brian Ripley [mailto:ripley at stats.ox.ac.uk]
Sent: 24 July 2003 16:56
To: michael watson (IAH-C)
Subject: RE: [R] Your proxy seems not to work with R (was R won't
connect to the internet on Linux!)

When I do (under tcsh)

env http_proxy=http://wwwcache.bbsrc.ac.uk:8080/ R
> options(internet.info=0)
> update.packages()
trying URL `http://cran.r-project.org/src/contrib/PACKAGES'
Using HTTP proxy http://wwwcache.bbsrc.ac.uk:8080

it tries to connect to your proxy (as it says) and gets no response, which
is not surprising from my site.  If you get the same, your proxy is
probably not behaving in the standard way (since that has been tested by
many users with standard proxies).

I've changed the emphasis of the subject line to one I feel is more 
equitable: many, many users have counter-evidence to your original 
assertion, which was rather arrogant.

On Thu, 24 Jul 2003, michael watson (IAH-C) wrote:

> Hello Professor
> If you are suggesting that I am simply missing the "http://" part of my
> cache URL, or that I am missing a trailing "/", then I pre-empted this
> response and it still doesn't work.

I was suggesting that `simply' you were not reading the documentation 

> I have tried setting both http_proxy and HTTP_PROXY to all of:

I hope you set to *each* of these.  The first and third are documented to
be incorrect, so using those was perverse.

> wwwcache.bbsrc.ac.uk:8080
> http://wwwcache.bbsrc.ac.uk:8080
> wwwcache.bbsrc.ac.uk:8080/
> http://wwwcache.bbsrc.ac.uk:8080/
> and I still get the same response - R cannot open the URL.
> And yes, that is thw right proxy address, I copied it straight from
> Netscape on the same computer, and Netscape connects to the internet
> fine.
> Thanks
> Mick
> -----Original Message-----
> From: Prof Brian Ripley [mailto:ripley at stats.ox.ac.uk]
> Sent: 24 July 2003 13:17
> To: michael watson (IAH-C)
> Cc: 'R-help at stat.math.ethz.ch '
> Subject: Re: [R] R won't connect to the internet on Linux!
> On Thu, 24 Jul 2003, michael watson (IAH-C) wrote:
> > OK, I really am struggling with this one!  Forgive me if I am being stupid....
> > I am running R 1.7.1 on Suse Linux 8.1.  I connect to the internet
> > through a proxy so I have:
> > 
> > IAHC-LINUX03:~ # echo $http_proxy
> > wwwcache.bbsrc.ac.uk:8080
> > IAHC-LINUX03:~ # echo $HTTP_PROXY
> > wwwcache.bbsrc.ac.uk:8080
> > 
> > just in case ;-)
> > 
> > SO, i go into R and I get:
> > 
> > > source("http://www.bioconductor.org/getBioC.R")
> > unable to connect to 'www.bioconductor.org' on port 80.
> > Error in file(file, "r") : cannot open URL `http://www.bioconductor.org/getBioC.R'
> > 
> > OK so is R just not picking up my proxy setting?  
> Your setting is wrong, so it is being ignored.  The help page says
> quite explicitly
>       The form of `"http_proxy"' should be `"http://proxy.dom.com/"' or
>      `"http://proxy.dom.com:8080/"' where the port defaults to `80' and
>      the trailing slash may be omitted.
> > It seems to be trying
> > port 80 on something, and I have specifically set it to port 8080 in my
> > environment variables.  As far as I can see I have followed the
> > reference manual suggestion, so does anyone else have one?
> The problem is in your seeing, it seems.

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-help mailing list