[R] failed to load MASS at start up

Douglas Bates bates at stat.wisc.edu
Wed Apr 16 23:02:59 CEST 2003

Michael Na Li <lina at u.washington.edu> writes:

> Just installed R-1.7.0 (with recommended libraries) on RedHat 8.0.  
> At R console, I can do
> > library (MASS)
> > 
> just fine.  However, if I put a line 'library(MASS)' into ~/.Rprofile, it
> fails to load,
> R : Copyright 2003, The R Development Core Team
> Version 1.7.0  (2003-04-16)
> ....
> Type `q()' to quit R.
> Error in get(x, envir, mode, inherits) : variable "biplot" was not found
> Error in library(MASS) : package/namespace load failed
> [Previously saved workspace restored]
> >
> What's happening?  I also tried to load 'lattice' (which I assume is where
> biplot is defined) before 'MASS', but got the same error.

biplot is in mva

> help.search('biplot')
Help files with alias or title matching 'biplot' using fuzzy matching:

corresp(MASS)           Simple Correspondence Analysis
Rows(lattice)           Miscellaneous Functions used within Lattice
panel.bwplot(lattice)   Default Panel Function for bwplot
barchart(lattice)       Common Bivariate Trellis Plots
biplot(mva)             Biplot of Multivariate Data
biplot.princomp(mva)    Biplot for Principal Components

By default mva is loaded but perhaps that does not occur until after
~/.Rprofile is executed.

More information about the R-help mailing list