[R] install.packages("grid") failed

Paul Murrell p.murrell at auckland.ac.nz
Thu Oct 3 06:16:16 CEST 2002


Yuelin Li wrote:
> I just successfully compiled R-1.6.0 on a Red Hat 7.2 machine.  When I
> tried to install "grid" from source, I got this error.  Any
> suggestions?  I don't think it is a dependency problem.  I also attach
> the output from library().

R-1.6.0 comes bundled with a new version of grid.  This should be
installed automatically during the build of R.  i.e., you do not need to
download and install grid separately, it should already be there if R
has built correctly.

The (old) version of grid on CRAN is not compatible with R-1.6.0.  We
will rectify this as soon as possible.  Apologies for the problems.

The good news is that you hopefully have grid installed.  The failed
install from CRAN should not have affected the grid that was
automatically installed when R built (at least, when I just tried doing
what you did I still have an installed, working grid).

Hope that helps.

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list