[R] installing R on Red Hat 7.1

Ray Brownrigg Ray.Brownrigg at mcs.vuw.ac.nz
Fri Jun 14 00:03:34 CEST 2002

> >When I did:
> >> rpm -ivh R-recommended-1.5.0-1.i386.rpm
> >error: failed dependencies:
> >	R-base = 1.5.0 is needed by R-recommended-1.5.0-1
> >	libblas.so.3   is needed by R-recommended-1.5.0-1
> >	libR.so   is needed by R-recommended-1.5.0-1
> You need to install R-base before R-recommended, or at the same
> time, by giving rpm ... two arguments.  And it is much better to
> use -Uvh rather than -ivh in general (unless you need both
> versions of something).
But I think you will find that even when you do install R-base first, or
concurrently, it will then discover that libreadline is out of date and
Tcl and Tk are not there (or perhaps also out of date - I didn't follow
up on this).  So I suspect you will need to upgrade your RedHat to 7.2
at least.

Ray Brownrigg
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list