[R] shared libraries on FreeBSD 4.*

loren mccarter lorenmc at socrates.berkeley.edu
Wed Oct 31 17:22:10 CET 2001

I've used R for a couple of years on FreeBSD with few problems. Recently,
a couple of the contributed packages seem to have difficulty finding
symbols in the shared libraries. Currently, I'm running R 1.3.1 on FreeBSD
4.4. I've tried setting LD_LIBRARY_PATH to /usr/local/lib
and some other things. The packages I've had trouble with are:

Matrix 0.3.15
RODBC 0.8.3
RSPython 0.3

Matrix could not find my BLAS library: 

     checking for dgemm_ in -lcomplib.sgimath... no
     checking for zherk in -lblas... no
     checking for dgemm_ in -lblas... no
     could not find your BLAS library
     ERROR: Configuration failed for package `Matrix'

I solved the problem with Matrix by adding -L/usr/local/lib to the 'FLIBS'
variable in $RHOME/etc/Makeconf. Then, it found the library and installed
just fine. 

RODBC gives me the following error:

   Installing source package `RODBC' ...
   creating cache ./config.cache
   checking for library containing SQLTables... no
   configure: error: no ODBC driver manager found
   ERROR: Configuration failed for package `RODBC'

I have unixODBC and libiodbc installed in /usr/local/lib and "nm
-g" returns the symbol SQLTables in libiodbc.so, libodbc.so,
libodbcpsql.so, libpsqlodbc.so. -L/usr/local/lib is in the FLIBS
statement so that is not the problem. 

RSPython installs fine, but when I load the library in R
'library(RSPython' it returns the following:

    Error in dyn.load(x, as.logical(local), as.logical(now)) : 
            unable to load shared library
      /usr/local/lib/R/library/RSPython/libs/RSPython.so: Undefined symbol
    Error in library(RSPython) : .First.lib failed

Am I correct in thinking that these three issues result from a
common problem with R and shared libraries on FreeBSD? Can
you think of something that I am doing incorrectly upon installation
or R or the packages that could cause these problems. In case it is
relevant, FreeBSD uses an older version of libtool as compared to the one
that comes with R. Here is the version information: 

FreeBSD libtool:
  ltmain.sh (GNU libtool) 1.3.4-freebsd-ports (1.385.2.196 1999/12/07

R libtool: 
  ltmain.sh (GNU libtool) 1.3e (1.890 2001/04/06 23:48:27)

Thanks for any help you can provide!


r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list