[R] update.packages() doesn't work anymore

s-luppescu@uchicago.edu s-luppescu at uchicago.edu
Wed Jan 24 21:25:14 CET 2001

On 24-Jan-2001 Peter Dalgaard BSA wrote:
> s-luppescu at uchicago.edu writes:
>> For some reason, update.packages(), one of the greatest features of R,
>> doesn't
>> work anymore (perhaps since I upgraded to 1.2.1?). It downloads the new
>> packages, but when it tries to build them, I get this message:
>> WARNING: ignoring environment value of R_HOME
>> /var/tmp/R-base-root/usr/lib/R/bin/Rcmd:
>> /var/tmp/R-base-root/usr/lib/R/bin/Rcmd: No such file or directory
>> I save the downloaded packages and then do R INSTALL <pkgname> at the
>> command
>> line, and it works fine. I tried setting lib=/usr/lib/R and also the R_HOME
>> environment var, but that didn't help. What am I doing wrong?
> What does "R RHOME" tell you?

[root at musuko:~] <14:22:44> 994  ->> R RHOME

> Is R_HOME set in the environment? If so, try removing it.

No. R_HOME is blank. I tried setting it to /usr/lib/R but had the same results.
Stuart Luppescu         -=-=-  University of Chicago
$(B:MJ8$HCRF`H~$NIc(B        -=-=-  s-luppescu at uchicago.edu
http://musuko.uchicago.edu/pubkey.asc for PGP Public Key
ICQ #21172047  AIM: psycho7070
I've known him as a man, as an adolescent and as a child -- sometimes
on the same day.
>> Sent on 24-Jan-2001 at 14:23:39 with xfmail
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list