[R] problem with installation from source on linux and solaris

Jennifer Steinbachs stein at fmnh.org
Fri Sep 8 18:25:12 CEST 2000

On the solaris 7 box, using the Sun make, the configuration works
ok.  Even running make works ok.  However, when I run "make check" all of
the tests fail.  It's a standard Ultra10, with full patches
applied...  and there are no errors generated during the make...

On the RH6.x linux box, configure works, make works, make check works,
make install works.  Hey, I can even see the R binary that gets dropped
into /usr/local/R-1.1.1/bin.  But when I try to run it, I get a text
message "welcome to R yada yada yada" and then it quite by saying that it
cannot access the base package.

And then last night on a different RH 6.2 linux box, using the SRPMS, my
husband (sys admin extraordinaire) tried making a new R rpm for me, but it
failed because it couldn't find one file (man/R.1 or something?) during
the rpm build.

I'd welcome any insights...


J. Steinbachs, Ph.D.
Computational Biologist
The Field Museum
Chicago, IL 60605-2496

office: 312-665-7810
fax: 312-665-7158

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list