[R] unsuccesfully making libRmath.a

Prof Brian D Ripley ripley at stats.ox.ac.uk
Mon Oct 30 08:28:05 CET 2000

On Mon, 30 Oct 2000, Ramon Diaz-Uriarte wrote:

> Dear All,
> I am having problems making and using the standalone library, after succesfully
> installing R from the tar.gz file (I am using Linux, with R-patched, but I have
> similar problems with R-devel).   
> First, when I do: 
> root at ligarto:/usr/lib/R-patched/src/nmath/standalone > make
> ....
> ar: mlutils.o: No such file or directory 
> make[1]: *** [libRmath.a] Error 1
> make[1]: Leaving directory `/usr/lib/R-patched/src/nmath/standalone' make: ***
> [archive] Error 2 
> I tried directly giving the names of the object files to ar, and it seems to
> work... but not really:
> > gcc -I/usr/lib/R-patched/src/include-L/usr/lib/R-patched/src/nmath/standalone  test.c -lRmath 
> /tmp/ccJAm46E.o: In function `main': 
> /tmp/ccJAm46E.o(.text+0x22): undefined reference to `qnorm5'
> collect2: ld returned 1 exit status                           
> What am I doing wrong?

Well, it's hard to know what you are doing!  Try unpacking the tar again,
configuring, cd src/nmath/standalone and running make.  That is, not
making R first.  If that does not work, please send me a complete

(Despite that advice, this has always worked for me on both Solaris and
Linux, but there seem to have been problems on older makes.)

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272860 (secr)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list