[R] Compiling R on RS6000 AIX 4.3

Peter Cameron peter.cameron at enscitech.com
Wed Jul 12 17:21:54 CEST 2000

> I think it's more complicated than that.  The last time I tried compiling
> R on AIX there was a configure problem with the BLAS functions.  The
> library libblas existed but the functions had the wrong names (due to
> differences in use of underscores by fortran compilers). This meant that R
> didn't compile its own BLAS but couldn't link to the system one either. I
> thought this had been fixed, though.

After being told that all these functions were in the blas.f file in
src/appl, I modified Makefile.in by adding:


immediately after the SOURCES_F = \ line.

This solved that compilation problem.

> There is a real problem with some C/Fortran combinations on AIX.

I've now successfully compiled version 0.90.0, tested and installed it.
Unfortunately, I haven't the time at the moment to further investigate the
compilation and execution failures of the latest releases.


r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list