[R] Compiling R on HP-UX

Peter Kleiweg kleiweg at let.rug.nl
Tue Aug 15 21:43:43 CEST 2000

Has anyone succeeded in compiling R on HP-UX?

I'm trying to compile R version 1.1.0 on a HP-UX 10.20
machine. I run into the following problems:

I got a compile error on src/unix/X11/rbitmap.c which I solved
by including setjmp.h. After that, and after editing the
Makefiles a bit cause gcc en ld can't find all the libraries, I
finally get it to compile. Then I run "make install", and it
looks OK. But R won't start. It complains it can't load
R_X11.sl, which I checked is definately in the place R is
looking for it. So I recompiled R linking all the sources that
go into R_X11.sl derictly into R.bin. No R does run, but it
crashes with a segmentation fault as soon as it tries to open a

Does anyone know about similar problems, and found a
solutions? I checked the archives for the last year, but
couldn't find any reference to this type of problem.

The `file' command gives some information that might be
informative. Or not. It says:

R.bin:     PA-RISC2.0 shared executable dynamically linked -not stripped
R_X11.sl:  PA-RISC1.1 shared library -not stripped

Both files were created in the same run from make.

I used gcc version 2.95.2.

I also tried gcc version egcs-2.91.60, but run into much more
trouble because it couldn't find "address indepedent" libraries
nessary to link R libraries.

I compiled R using gcc version on Linux 2.0.36 and had
no problems.

And another thing: "configure" on HP-UX says it can't use
tcl/tk, but it can on Linux. But my Linux and the HP-UX
machine have identical versions of tcl and tk installed.

Peter Kleiweg

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list