[R] make errors while compiling

Kieran Healy kjhealy at princeton.edu
Sat Dec 11 06:50:28 CET 1999

Dear R users -

I am a first-time R user trying to compile v.0.90.0 under Caldera
OpenLinux 2.3, on a Dell PII400/128. I've encountered a problem with the
make file. 

First, I run configure, which appears to complete properly. (I had to
download an updated gcc library from caldera for this to happen though.)
At the end of its run, config reports:

> R is now configured for i686-unknown-linux
>  Source directory:         .
>  Installation directory:   /usr/local
>  C compiler:               gcc  -mieee-fp -g -O2
>  FORTRAN compiler:         g77  -g -O2
>  Gnome support:            no                        

Then I run make. It terminates after a few lines as follows:

[ -- some initial lines snipped -- ]
making Rsock.d from Rsock.c
In file included from /usr/include/bits/posix1_lim.h:126,
                 from /usr/include/limits.h:30,
                 from Rsock.c:28:
/usr/include/bits/local_lim.h:27: linux/limits.h: No such file or
In file included from /usr/include/errno.h:36,
                 from Rsock.c:32:
/usr/include/bits/errno.h:25: linux/errno.h: No such file or directory
In file included from /usr/include/signal.h:294,
                 from Rsock.c:156:
/usr/include/bits/sigcontext.h:28: asm/sigcontext.h: No such file or
make[3]: *** [Rsock.d] Error 1
make[3]: Leaving directory `/root/R-0.90.0/src/appl'
make[2]: *** [R] Error 2
make[2]: Leaving directory `/root/R-0.90.0/src/appl'
make[1]: *** [R] Error 1
make[1]: Leaving directory `/root/R-0.90.0/src'
make: *** [R] Error 1                                 

[ -- end -- ]

The files make appears to be complaining about do exist on my system. In
each case make seems to find the file (eg, /usr/include/bits/errno.h)
but then complains seems to refer to a different directory --
linux/errno.h --- and says `No such file'. If linux/ and asm/ are meant
to be directories with these files inside, they don't exist on my
system. I've tried several clean installs and get the same result each

RPM says I'm using the following C and Fortran packages:


I don't have much experience compiling files of this sort, so I can't
interpret the error messages properly. I'd be very grateful for advice
on what I'm doing wrong, and how to remedy it.


Kieran Healy

Kieran Healy              email: kjhealy at princeton.edu 
Department of Sociology   
Princeton University      
Princeton, NJ 08544-1010
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list