[R] R-0.64.0 installation on SGI IRIX 6.5 machine

Jayshree Sarma jsarma at cs.gmu.edu
Thu Apr 29 21:18:37 CEST 1999


I am trying to install R-0.64.0 version on SGI machine running
IRIX 6.5.

Machine details:
319 <mind.krasnow.gmu.edu:R-0.63.3> uname -a
IRIX64 mind 6.5 07271714 IP27

Configure script runs fine and the output at the end of configure is:

R is now configured for mips-sgi-irix6.5

  Source directory:         /usr/local/R-0.64.0
  Installation directory:   /usr/local
  C compiler:               gcc -g
  FORTRAN compiler:         /usr/local/bin/g77  
  Gnome support enabled:    no

I am using gcc (egcs1.1.1) and g77 combination.
I use the GNU make(version 3.77) rather than the sgi make.
I went through your help mailing list and found that
I have to edit the Mathlib.h file in src/include directory
to undefine certain definitions which conflict with sgi's

When I run "gmake test", it fails; the details are given below.

gmake[5]: Entering directory
Building system startup profile
gmake[5]: Leaving directory `/usr/local/R-0.64.0/src/library/profile'
gmake[4]: Leaving directory `/usr/local/R-0.64.0/src/library'
gmake[3]: Leaving directory `/usr/local/R-0.64.0/src'
You should `make docs' now ...
gmake[2]: Leaving directory `/usr/local/R-0.64.0'
LC_ALL=C ../bin/R --vanilla < simple-true.R > simple-true.Rout
Comparing `simple-true.Rout' to
`/usr/local/R-0.64.0/tests/simple-true.Rout.save' ... OK
LC_ALL=C ../bin/R --vanilla < simple-tests.R > simple-tests.Rout
Comparing `simple-tests.Rout' to
`/usr/local/R-0.64.0/tests/simple-tests.Rout.save' ...17c17
< [1] FALSE
> [1] TRUE
gmake[1]: *** [simple-tests.Rout] Error 1
gmake[1]: Leaving directory `/usr/local/R-0.64.0/tests'
gmake: [test-All] Error 2 (ignored)

The test that fails from the simple-test.Rout file is

> Meps <- .Machine $ double.eps
> abs(1- .Machine$double.xmax * 
       10^(-.Machine$double.max.exp*log10(2)))/Meps < 1e3

According to the file the test should return true but get a false on this

I ran R and printed the list of objects:

List of 14
 $ double.eps           : num 2.22e-16
 $ double.neg.eps       : num 1.11e-16
 $ double.xmin          : num 2.23e-308
 $ double.xmax          : num 1.80e+308
 $ double.base          : int 2
 $ double.digits        : int 53
 $ double.rounding      : int 2
 $ double.guard         : int 0
 $ double.ulp.digits    : int -52
 $ double.neg.ulp.digits: int -53
 $ double.exponent      : int 11
 $ double.min.exp       : int -1022
 $ double.max.exp       : int 1024
 $ integer.max          : int 2147483647

All these outputs match with the numbers I found on the help mailing list.

Can someone tell why the test returns false? Should I be using some other
combination (sgi cc instead of gcc) to make this test work?


Jayshree Sarma
ps: reply to jsarma at cs.gmu.edu - I do not subscribe to the r-help list.

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list