R-beta: windows and dynload. Win95 ver B cann't dyn.load either

Douglas Steele dsteele.demon.co.uk at dsteele.demon.co.uk
Sat Oct 10 14:16:18 CEST 1998


It has been recently reported that dyn.load doesn't work on Win95a but
does on b and c (see Prof Ripley's quote below).  I originally had
version a but it did dyn.load, although occasionally complained.  During
this time I could build R and all demos etc worked fine, plus could make
new Fortran and C DLL's and interface OK (this being my main interest
with R).  Inexplicably though, dyn.load suddenly stopped working (with
the reported error below).  I used Guido's R0.62.3 throughout.

I had been intending to upgrade hardware and Win95 anyway so this seemed
a reasonable time.  I am now running Win95 4.00.950 B and my hardware
upgrade is to 333MHzK2 (was 100MHz Cyrex), 64MBRam (was 16MB), HD1.5GB

Now that I am running version B, the problem remains.

1) With build using Mumits Mingw version 1.02, R starts OK but when
attempting to dyn.load results in the following error...

        ---- ~~~~~~~~

Type  <Return>   to start : 

> dyn.load(paste(getenv("RHOME"), "demos/dynload/zero.dll", 
            sep = "/")) 
Error in dyn.load(x) : unable to load shared library "C:\R-

(Other demo's work ok)

2) With build using Mumits Mingw version 1.1, R fails on startup with...

R : Copyright 1998, The R Development Core Team
Version 0.62.3 Beta (Sept 8, 1998)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type    "?license" or "?licence" for distribution details.

R is a collaborative project with many contributors.
Type    "?contributors" for a list.

Type    "demo()" for some demos, "help()" for on-line help, or
        "help.start()" for a HTML browser interface to help.

Error: 0 arguments passed to ".Internal" which requires 1.

The graphics window doesn't open in this case.

Typing demo(dyn.load) results in the same error message.
If demo(graphics) given, graphics window opens, no output to it, and
same message.

I agree with the comment that the cross-compiled version supplied by
Guido in the binary distribution works OK.

To see if Mingw32 v1.1 didn't have the dyn.load problem, I took the DLL
built with Mingw1.1 locally and substituted it for Guido's cross-
compiled version.  I then ran the full binary distribution cross-
compiled R.exe with the locally built DLL (Mingw ver 1.1).  This
resulted in the "cann't load" error as before.

In conclusion it would seem...

a) dyn.load does not work (on all) Win95 version B systems (and I
suspect version C as well). Dyn.load did work inconsistently on version
A with me but suddenly stopped.  Therefore it is probably correct to say
that later versions of Win95 do not cure the dyn.load problem.

b) building with Mingw32 version  1.1 results in an additional error,
and has been reported by Prof Ripley, dyn.load still doesn't work

c) only the cross-complied version works properly

In article <Pine.GSO.3.96.980917063426.11242A-100000 at localhost>, Prof
Brian D Ripley <ripley at stats.ox.ac.uk> writes
>On Wed, 16 Sep 1998, Troels Ring wrote:
>> I get an error:
>> Error in dyn.load(file) : unable to load shared library
>> "D:\R_CODA\RW0613\library\eda\libs\eda.dll"
>> with almost all the packages. I tried to use "require" and tried also to
>> copy the dll's to the bin directory and nothing helped.
>> Any ideas ?
>This happens on certain Windows 95 machines (at least); Guido Masarotto and
>I traced it to machines running Windows 95a (that is the original W95 with
>service pack 1); machines running Windows 95b or c (OSR2 and OSR2.5) are
>able to dyn.load.  We thought compiling under a later compiler (egcs 1.1) 
>might help, but it does not (report to Guido: I tried this last week). 
>The good news is that cross-compiling from Linux does seem to work: the
>version Guido announced on R-announce yesterday of 0.62.3 does allow
>dyn.load on the machines here that had problems with rw0613, and since it
>has a much faster interface (and IMHO nicer interface) and is the current
>0.62.3, I suggest you try that instead. It does have fewer libraries as
>yet, but since you cannot use them with rw0613, that is no disadvantage. 
Douglas Steele
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list