R-beta: R-0.62.1 under Digital Unix

Mark A. Beaumont M.Beaumont at ucl.ac.uk
Wed Jul 1 13:25:37 CEST 1998

I am grateful for the advice of Douglas Bates on my earlier problem in making
R-0.62.1, but I'm afraid I'm still having problems....

I have been installing the various updates to R for quite some time on my
alpha, and it is only now that I have been having really severe problems.

The three or 4 versions before 0.61.1 installed without error. For 0.61.1 I
needed to install GNU make.

For 0.62.2 I have so far needed to
(a) edit the Makefile in src/graphics, as mentioned in my previous email

(b) edit the config.site to give a -fpe3 flag to the DEC f90 compiler (this
is more a precaution in case of fp exceptions in the fortran code)

(c) edit the Makeconf file to explicitly give "-nofor_main -fpe3" flags to
f90 in LDCMD (because it doesn't seem to be accepted when put in

(d) install GNU install (suggested by Douglas Bates)

this then produces a successful "make"

Following my previous practice I then make a symbolic link to R from
/usr/local/bin. However when I then run R I get.

...opening messages...

Error: memory exhausted
> 1+1
[1] 2
> a <- c(1,2,3,4)
> a
[1] 1 2 3 4
> help()
Error: Object ".Library" not found
> help(c)
Error: Object ".lib.loc" not found

I don't recall having this before.
Obviously it is unable to find various things. So I thought something might
have changed from previous versions, so I did "make install" which I have
tended not to do before. When I did this I
got group/ownership errors with tar and the make failed. So then (following
the previous patterns) I installed GNU tar. "make install" then worked
fine, But I still get the same problems when trying to run R.

I think I'm almost there....Any ideas ?

Best wishes,

Mark A. Beaumont
Institute of Zoology
Zoological Society of London
Regent's Park
London NW1 4RY UK
Tel:  0171 449 6617
Fax: 0171 586 2870
m.beaumont at ucl.ac.uk

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list