R-beta: Re: dse+redhat 4.2 problem

Paul Gilbert pgilbert at bank-banque-canada.ca
Wed Feb 25 17:52:50 CET 1998

 >R INSTALL dse     rlibs
>Installing package `dse' ...
>gcc -g -fpic -I/usr/local/R-0.61/include   -c dsefor.c -o dsefor.o
>/tmp/cca02533.i:1: numeric constant with no digits
>/tmp/cca02533.i:1: numeric constant with no digits
>is there something wrong with my gcc or is there some
>option missing somewhere?

>I suspect the problem might have to do with f2c. I think I
>installed g77 after I install R.  R seems to be working.
>g77 seems to be working, but it seems that I have several
>f2c.h around and the dse installation is using the f2c that
>came with R.  I have tried to use different f2c and that
>seems to change the error but not solve the problem.

Helgi Tomasson

In the dse directory which R INSTALL uses there are directories dse/src and
dse/src-c. The first has the original fortran source and the second has C code
which I have already translated with f2c. Both of these directories also have
Makefiles but it is really only necessary to use one of them. I don't exactly
understand the R INSTALL strategy, but it seems that if you have a fortran
compiler when you configure R then it may chose to use fortran, and otherwise it
won't. I think if you delete or rename one of the Makefiles then you will force
the use of the other.

There has been a reported problem with the g77 fortran compiler, so it is
probably best not to use that for the time being. From your report it looks like
you are using gcc on the C code, not g77.

If you use the C code version you will not need f2c, but you will need the f2c
libraries. With elf Linux I would have thought that not having the f2c libraries
would cause run time errors, not compile time errors, but that does not
necessarily seem to be true. I have run DSE with R under an older Slackware
version of Linux which had f2c installed. Last night I tried to run it under
RedHat 4.2 and discovered I did not have the f2c libraries install. I was also
re-installing R. While I've gone completely to elf I also discovered that some
thing (I can't remember if it was the R make or the R INSTALL dse) was looking
for libf2c.a, not the .so version. I'm not sure why that is, and I didn't have
time to finish.

I posted your previous message on the R-devel list but so far I have had no
response. I don't think that you will get much help on this from my boc_dse list
as I don't think many people on that list are using the Linux version yet. The
code is in the devel part of CRAN for the reason that the make/install
procedures have not been widely tested - please persist, I think the code works
very well under R/Linux once you get it installed. If you do discover the reason
for the problem I would appreciate hearing about the resolution.

Paul Gilbert

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list