R-beta: ld problem/SunOS/gcc/g77

Ross Ihaka ihaka at stat.auckland.ac.nz
Fri Aug 14 22:21:34 CEST 1998

	From r-help-owner at stat.math.ethz.ch Sat Aug 15 05:32 NZS 1998
	Date: Fri, 14 Aug 98 10:29:11 PDT
	From: "Charles C. Berry" <cberry at tajo.ucsd.edu>
	To: r-help at stat.math.ethz.ch
	Subject: R-beta: ld problem/SunOS/gcc/g77

	In trying to compile R-0.62.2 on my SPARC SunOS: 

	tajo% uname -a
	SunOS tajo 4.1.3_U1 1 sun4m

	with gcc/g77,

	I ran into 

	gcc  -o R.binary [deleted] ../lib/libmath.a 
		-L/usr/openwin/lib -lX11  -ldl -ltermcap -lm -lf2c
	collect2: ld returned 2 exit status
	ld: /lib/libm.a(lgamma.o): _gamma: multiply defined
	ld: /lib/libm.a(lgamma.o): _lgamma: multiply defined
	*** Error code 1
	make: Fatal error: Command failed for target `R.binary'
	Current working directory /usr/local/RHOME/R-0.62.2/src/main
	[rest deleted]

	which I assume is due to some 'collision' of the various
	libraries supplied by R, gcc, g77, and Sun.

One "quick hack" you could try is to put the definition

	#define gamma Rgamma
	#define lgamma Rlgamma

at the top of the file ~R/src/include.

I haven't tried this myself.  It is just a guess as to what might

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list