R-beta: compiling R with libncurses on SuSE Linux

Albrecht Gebhardt agebhard at zidsrv.sci.uni-klu.ac.at
Tue May 6 15:39:19 CEST 1997

When I tried to compile R on a S.u.S.E-4.4 linux box, I ended up with
unresolved symbols from libtermcap. So I decided to use the newer libncurses.

Applying the following patch to configure.in and creating a new
configure script with "autoconf  configure.in > configure" solved my problems.

--- configure.in.orig   Tue May  6 15:05:20 1997
+++ configure.in        Tue May  6 15:05:23 1997
@@ -142,13 +142,17 @@
-#  This is set up so we only get one of one of -ltermcap and -ltermlib
+#  This is set up so we only get one of one of -lncurses -ltermcap and -ltermlib
 AC_CHECK_LIB(m, sin)
+AC_CHECK_LIB(ncurses, main)
+if test -z "HAVE_LIBNCURSES"
 AC_CHECK_LIB(termcap, main)
 if test -z "HAVE_LIBTERMCAP"
 AC_CHECK_LIB(termlib, main)
 AC_CHECK_LIB(readline, main)
 AC_CHECK_LIB(dl, dlopen)

Albrecht Gebhardt                   email   : albrecht.gebhardt at uni-klu.ac.at
Institut fuer Mathematik            Tel.    : (++43 463) 2700/837
Universitaet Klagenfurt             Fax     : (++43 463) 2700/834
Villacher Str. 161
A-9020 Klagenfurt, Austria

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list