[Rd] problem adding gdb to RTOOLS40 on Windows

Bravington, Mark (Data61, Hobart) M@rk@Br@v|ngton @end|ng |rom d@t@61@c@|ro@@u
Thu Apr 15 06:52:41 CEST 2021

I've not been able to install gdb for RTOOLS40 on Windows 10. The rtools installer (rtools40-x64_86.exe) doesn't seem to include gdb by default, and when I follow the instructions for adding gdb (which I tracked down at https://github.com/r-windows/docs/blob/master/faq.md) this is what happened:

<cd to c:\rtools\rtools40>
<run mingw64.exe>
$ pacman -S mingw-w64-x86_64-gdb
resolving dependencies...
looking for conflicting packages...

Packages (8) mingw-w64-x86_64-expat-2.2.9-9002

Total Download Size:    3.46 MiB
Total Installed Size:  83.77 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
error: failed retrieving file 'mingw-w64-x86_64-gdb-8.3.1-9500-any.pkg.tar.xz' from cloud.r-project.org : The requested URL returned error: 404
error: failed retrieving file 'mingw-w64-x86_64-gdb-8.3.1-9500-any.pkg.tar.xz' from cran.r-project.org : The requested URL returned error: 404
error: failed retrieving file 'mingw-w64-x86_64-gdb-8.3.1-9500-any.pkg.tar.xz' from dl.bintray.com : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.

Something very similar happens if I try the 32bit version.

Do you have any suggestions?

 - I used to have this stuff working OK with R3.6/RTOOLS35 but have not needed to go back to C for a while. The version of gdb in RTOOLS is 7.9.1; I tried copying that gdb.exe into RTOOLS40 but it just exited instantly when I tried to run it from there. 
 - NB I have absolutely no idea what is meant by msys2 or pacman or any of that, I'm just following instructions... 



Mark Bravington
CSIRO Marine Lab

More information about the R-devel mailing list