[Rd] Matrix loading hangs on AIX 5.3 with 3.1.2

derjones derjones at us.ibm.com
Wed Jun 3 20:37:34 CEST 2015

Hi all,

Yes, I know 5.3 is old, but it's a system I have to work with at present.

I have the latest supported xlC + friends. gcc building is not an option on
this system for other reasons.

I have read the install instructions and set the env vars according to those
and also am using the freeware iconv and other GNU tools where needed. 

Problem - the Matrix package hangs on installing.

Gets to:

  Loading required package: Matrix

and then nothing. Left overnight even.

My env vars look like this:

export OBJECT_MODE=64
export LIBICONV=/opt/freeware
export CC="xlc_r -q64" 
export CFLAGS="-O -qstrict"
export CXX="xlC_r -q64"
export CXXFLAGS="-O -qstrict"
export F77="xlf_r -q64"
export AR="ar -X64"
export CPPFLAGS="-I$LIBICONV/include -I/usr/lpp/X11/include/X11"
export LDFLAGS="-L$LIBICONV/lib -L/usr/lib -L/usr/X11R6/lib"

xlc -qversion
IBM XL C/C++ for AIX, V12.1 (5765-J02, 5725-C72)
Version: 12.01.0000.0011

xlC -qversion
IBM XL C/C++ for AIX, V12.1 (5765-J02, 5725-C72)
Version: 12.01.0000.0011

xlf -qversion
IBM XL Fortran for AIX, V12.1
Version: 12.01.0000.0000

I have tried with R_SHELL set to bash and ksh. My login shell is bash.

I have tried with enable static and disable shared.

I have subsequently built without recommended packages. R build and
installs. (Minor issue with the location of libRblas but I solved that. 

I have then tried doing a install.packages("Matrix") from R.

Same thing. Hangs. 

Any ideas? 

I can supply more information as needed. Please let me know what you would
like to know.

Kind regards

Derek Jones
Senior Software Engineer, CTG at IBM.

View this message in context: http://r.789695.n4.nabble.com/Matrix-loading-hangs-on-AIX-5-3-with-3-1-2-tp4708136.html
Sent from the R devel mailing list archive at Nabble.com.

More information about the R-devel mailing list