[Rd] Testing R packages on Solaris Studio

Jeroen Ooms jeroenooms at gmail.com
Sat Apr 11 03:49:46 CEST 2015

I prepared a vm image to make testing on Solaris a bit easier. It is
based of the official Oracle Solaris 11.2 VM template and includes two
preinstalled versions of R, two compilers and some other software:

 - Solaris Studio 12.3
 - Oracle R Distribution aka ORD (uses Solaris Studio)
 - OpenCSW:
   * r_base (uses GCC)
   * gcc4g++ and gcc4gfortran
   * git
   * vim

The image is distributed in the open ova format and should work in
most virtualization environments. More information is available on

That said, I still have not figured out how to build Rcpp and RJSONIO
with ORD/SolarisStudio. They compile without problems using
r_base/gcc, but with ORD I still get the same errors described below.
I would be very interested to learn how CRAN builds/tests these
packages on Solaris.

On Thu, Jan 8, 2015 at 12:52 PM, Jeroen Ooms <jeroenooms at gmail.com> wrote:
> I have setup a Solaris server to test packages before submitting to
> CRAN, in order to catch problems that might not reveal themselves on
> Fedora, Debian, OSX or Windows. The machine runs a Solaris 11.2 vm
> with Solaris Studio 12.3.
> I was able to compile current r-devel using the suggested environment
> variables from "R Installation and Administration" and:
>   ./configure --prefix=/opt/R-devel --with-blas='-library=sunperf' --with-lapack
> All works great (fast too), except for some CRAN packages with c++
> code won't build. The compiler itself works, most packages (including
> e.g. MCMCpack) build OK. However packages like Rcpp and RJSONIO fail
> with errors shown here:
> https://gist.github.com/jeroenooms/f1b6a172320a32f59c82.
> I tried installing with GNU make, but that does not seem to be the problem
>   configure.vars = "MAKE=/opt/csw/bin/gmake"
> I am aware that I can work around it by compiling with gcc instead of
> solaris studio, but I would specifically like to replicate the setup
> from CRAN.
> Which additional args/vars/dependencies do I need to make Rcpp and
> RJSONIO build as they do on the CRAN Solaris server?
>> sessionInfo()
> R Under development (unstable) (2015-01-07 r67351)
> Platform: i386-pc-solaris2.11 (32-bit)
> Running under: Solaris 11
> locale:
> [1] C
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base
> loaded via a namespace (and not attached):
> [1] tcltk_3.2.0 tools_3.2.0

More information about the R-devel mailing list