[Rd] Mac v Windows Mystery

Roger Koenker rkoenker at illinois.edu
Wed Jan 30 17:37:49 CET 2013

Dear All,

I'm trying to track down a problem with my quantreg package reported by a user doing censored quantile regression.
When he runs the test4.R file attached below (which reads the csv file also attached) on his windows machine he gets
an error like this:

> Error in dimnames(B) <- list(c("tau", dimnames(x)[[2]], "Qhat"), NULL) :
>   length of 'dimnames' [1] not equal to array extent
> In addition: Warning message:
> In rbind(grid[1:J], B, qhat) :
>   number of columns of result is not a multiple of vector length (arg 2)

However, when I run the same thing on my mac there is no error, no warning.  And --
more strangely-- running this on another windows laptop here in Urbana also encounters
no problems.  I thought that this might just be a seed problem since there is a bootstrapping
step at the end, but the original user has tried several seeds and always gets this error.
We are all running 2.15.1 and V4.94 of quantreg.  I understand that YMMV, especially on
windows,  but it is difficult to debug this sort of thing when I can't reproduce it.  Any suggestions
or other experience would be welcome.  The test problem takes a minute or so to run on my


url:    www.econ.uiuc.edu/~roger            Roger Koenker
email    rkoenker at uiuc.edu            Department of Economics
vox:     217-333-4558                University of Illinois
fax:       217-244-6678                Urbana, IL 61801

-------------- next part --------------
-------------- next part --------------

More information about the R-devel mailing list