[Rd] configure-args for R CMD build

Kasper Daniel Hansen kasperdanielhansen at gmail.com
Sun Jan 15 17:02:34 CET 2012

On Sun, Jan 15, 2012 at 10:48 AM, Finak, Greg <gfinak at fhcrc.org> wrote:
> I think you need to enclose the arguments to configure-args in quotes.
> i.e.
> --configure-args='--with-graphviz=/Users/khansen/Source/usr'

I did, I was quoting the error message, not the command where I use

R CMD build --configure-args='--with-graphviz=/Users/khansen/Source/usr'

Note that I said the same command works for R CMD INSTALL.  Also, it
is clearly documented that R CMD build does not support
--configure-args.  My suggestion is that it probably ought to.

Btw, same comment but for R CMD check, which I forgot to mention in my
original post.


> On 2012-01-15, at 7:43 AM, "Kasper Daniel Hansen"
> <kasperdanielhansen at gmail.com> wrote:
> When I build a package containing a vignette, the package gets
> installed to build the vignette.  However, it appears that R CMD build
> does not allow for --configure-args.  In my case, I have a C library
> installed in a non-standard position, and I need to tell the package
> where it is.  It works fine with R CMD INSTALL, but R CMD build
> complains
>  Warning: unknown option
> ‘--configure-args=--with-graphviz=/Users/khansen/Source/usr’
> and the subsequent installation fails with an error.
> Suggestion: allow R CMD build to accept --configure-args (and probably
> also --configure-vars)
> Best,
> Kasper
> ______________________________________________
> R-devel at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel

More information about the R-devel mailing list