[Rd] cygwin R-2.14.0 build fail

marco atzeri marco.atzeri at gmail.com
Wed Nov 16 16:11:57 CET 2011

On 11/12/2011 3:25 PM, Mark Carter wrote:
> I tried to build R-2.14.0 on cygwin using the commands:
> ./configure --with-x=no
> make
> I started to get a whole lot of errors starting with:
> /cygdrive/c/Users/mcarter/src/R-2.14.0/src/modules/internet/Rhttpd.c:275: undefined reference to `_R_InputHandlers'
> which I have pasted at
> http://pastebin.com/GFb2pq92
> I'm aware that there is a cygwinports ports, but it seems outdated, and when I tried installing it, it was very lengthy and seemed more trouble that it was worth. I abandoned the installation attempt.
> Any tips on a way forward?

just built R-2.14.0 deriving from R-2.13.1-1 of cygport.

   configure     --with-blas="$(pkg-config --libs blas)" \
                 --with-lapack \
                 --enable-R-shlib \
                 TCLTK_LIBS="-ltcl84 -ltk84"  \
                 --with-system-zlib \
                 --with-system-bzlib \
                 --with-system-pcre \
                 --with-system-xz \

almost all test passed

$ grep OK  R-2.14.0-1-check.log |wc -l

only 3 minor failures

$ find ../build/ -name *fail

If you are interested I can provide you the binary package.


More information about the R-devel mailing list