[Rd] cygwin R-2.14.0 build fail

peter dalgaard pdalgd at gmail.com
Sat Nov 12 21:28:46 CET 2011

On Nov 12, 2011, at 15:25 , Mark Carter wrote:

> I tried to build R-2.14.0 on cygwin using the commands:
> ./configure --with-x=no
> make
> I started to get a whole lot of errors starting with:
> /cygdrive/c/Users/mcarter/src/R-2.14.0/src/modules/internet/Rhttpd.c:275: undefined reference to `_R_InputHandlers'
> which I have pasted at 
> http://pastebin.com/GFb2pq92
> I'm aware that there is a cygwinports ports, but it seems outdated, and when I tried installing it, it was very lengthy and seemed more trouble that it was worth. I abandoned the installation attempt.
> Any tips on a way forward?

As far as I can tell, what is happening to you is that cygwin needs special configuration to build .dll libraries and ./configure does not know how to set that up.

R is not officially supported under Cygwin. Basically, we - er, Brian, mostly, I think - tried it several years ago, and it broke so many times that patience ran out. 

Others seem to be having better luck with recent versions (Google finds something that looks like ports of 2.13.2, so you might just need a little patience to get 2.14.0), but I think you're altogether better off over on


> ______________________________________________
> R-devel at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel

Peter Dalgaard, Professor,
Center for Statistics, Copenhagen Business School
Solbjerg Plads 3, 2000 Frederiksberg, Denmark
Phone: (+45)38153501
Email: pd.mes at cbs.dk  Priv: PDalgd at gmail.com

More information about the R-devel mailing list